Firmware unable to read data

Post Reply
Posts: 2
Joined: Wed Jun 04, 2014 2:59 pm

Firmware unable to read data

Post by Sim209 » Wed Jun 04, 2014 3:34 pm

Hi everybody,

Yesterday, my HMNHD-CE crashed (not really a crash, it's still working but i'll explain that later), and i searched accross the web to find something to help me.
Finally, i found your community. Nas-Central is really nice, and usefull... and allows us to make some great discoveries (Network Hard Drive hacking, ...and the possibility of install OMV on it :-) ).

So, last night, my HMNHD-CE freezed. I tried to restart it, and it (partly) worked.

I'm unable to access the shared folder via my OS. The Web Interface is working... But... it lost all sharing and told me that my hard drive is empty.

I was affraid of loosing all my data and i began to play! I have dissambled my HMNHD-CE following this page .
I took the HD and connected it to my (x)Ubuntu laptop.
I became able to read the XFS partition with this post.
And... Wonderful, all my data was here!

So, I've data on my HD, the firmware is working... But both didn't work together (The firmware didn't see the data :( )
How can i restore the data for making them readable by the firmware? Is it possible to do it without making a full backup (i don't have a DD with 2.1 Tb free space)?

My priority is to restore my HMNHD-CE, but I'm also interested by installing OMV. So if the solution involve OMV, it's not a problem :-)
(It is possible to install OMV without deleting data?)

Thanks a lot, for your help :-)


Ps: My english is far to be perfect... Sorry!!!

Post Reply