Transmission Working

Post Reply
riza
Posts: 4
Joined: Sat Aug 13, 2011 8:42 pm

Transmission Working

Post by riza » Sat Aug 13, 2011 8:46 pm

I managed to get transmission working on Home Media Cloud edition by doing this

http://iomega.nas-central.org/wiki/Home_Media_Optware
Installing Optware

Before you carry out this procedure you need to have enabled telnet and root access. Otherwise all the dependencies you need are already installed. Here is what you need to do:

export feed=http://ipkg.nslu2-linux.org/feeds/optwa ... s/unstable
export ipk_name=`wget -qO- $feed/Packages | awk '/^Filename: ipkg-opt/ {print $2}'`
wget $feed/$ipk_name
tar -xOvzf $ipk_name ./data.tar.gz | tar -C / -xzvf -
mkdir -p /opt/etc/ipkg
echo "src cross $feed" > /opt/etc/ipkg/feeds.conf

Installing Packages

You should now already have Optware installed and configured as per the section above. Now we are going to update and install nano:

export PATH=/opt/bin:$PATH
ipkg update
ipkg install nano

Post Install Configuration

You need to set /opt/bin to permanently be in your PATH environment variable. On this device for the root user you should add the following to the bottom of /root/.profile

export PATH=/opt/bin:$PATH

----------------------------------------

New version of Transmission based on the 1.3 branch is now available via ipkg install. Most of the instructions below the dividing line are now invalid. Transmission 1.3x comes with Clutch Web UI.

1) setup optware ipkg
2) # ipkg update
3) # ipkg install transmission

4) forward port 51413 to NAS

5) (recommend to create and login as a non-root user, root user might work too)
6) $ mkdir -p $HOME/Downloads
7) $ /opt/bin/transmission-daemon -w $HOME/Downloads
$ pidof transmission-daemon # should return 3 process ID's
8) connect to web UI http://YOUR-NAS-IP-ADDRESS:9091/

The above should get you started, usage of the web UI should be straight-forward. If you have any problem starting transmission-daemon on step 7

7.1) # killall transmission-daemon
7.2) # /opt/bin/transmission-daemon -h
7.3) # /opt/bin/transmission-daemon -f



had to restart demon 2 times from then on it all worked perfect. i changed the download folder to the pools directory to Documents. GUI works perfectly and loving it.

is there any harm in doing this?

allenb
Posts: 6
Joined: Mon Aug 08, 2011 5:37 am

Re: Transmission Working

Post by allenb » Mon Aug 15, 2011 5:30 am

Well done Riza!

Following on, I have it up and running, but found a couple of things in the instructions.
You need to set /opt/bin to permanently be in your PATH environment variable. On this device for the root user you should add the following to the bottom of /root/.profile
I don't have /root on the system, so I ignored this for now.
5) (recommend to create and login as a non-root user, root user might work too)
I created another user, but kept getting Permission Denied. I ended up running it as root OK.
7) $ /opt/bin/transmission-daemon -w $HOME/Downloads
This worked, but I couldn't log in using the web interface. In the end I had to edit the Transmission setting.json file to include my network.

Code: Select all

nano .config/transmission-daemon/settings.json

then change the line
    "rpc-whitelist": "127.0.0.1",
with
    "rpc-whitelist": "127.0.0.1,192.168.1.*",
or whatever your network range is.
Then, it all works perfectly ... except that it isn't persistent. After a reboot you need to go back and re-edit the file, and start transmission again. But, this is a minor inconvenience, and probably solvable.

Now, just need to get SlimServer running and all will be good in the world.

riza
Posts: 4
Joined: Sat Aug 13, 2011 8:42 pm

Re: Transmission Working

Post by riza » Mon Aug 15, 2011 7:02 pm

yes just need to find a way to make it permanent if anyone knows how to do it please let me know.

zorofroozo
Posts: 1
Joined: Tue Sep 06, 2011 4:06 pm

Re: Transmission Working

Post by zorofroozo » Tue Sep 06, 2011 4:11 pm

I'm working on it, i've allready got it permanent but it slow the bootup with about 10 minutes and reboots become impossible

I'll keep ya posted when i've finished my mod

keeperX
Posts: 8
Joined: Sat Dec 24, 2011 4:09 am

Re: Transmission Working

Post by keeperX » Tue Jan 03, 2012 4:28 am

I don't know how to make it permanent. However, I found I can use -g option to designate the folder containing setting.json.

So I copied my setting file to a permanent folder, and using something like "/opt/bin/transmission-daemon -w /mnt/pools/A/A0/Downloads -g /mnt/pools/A/A0/Downloads" to start transmission after SSH into CE. Convenient enough for me.

Note, I use /mnt/pools/A/A0/Downloads as my download folder, with the setting file inside.

User avatar
Marvin
Posts: 3
Joined: Sat Mar 17, 2012 11:21 am

Re: Transmission Working

Post by Marvin » Sun Mar 18, 2012 12:15 am

I found a way to make it permanent:

First I logged in as root and created a user (to the previously existing group "users" with gid 100):

Code: Select all

useradd -g 100 user
Then I transferred the home directory to a more permanent location than the default /home/user (which would be removed after reboot):

Code: Select all

mkdir /mnt/pools/A/A0/user
chown user:users /mnt/pools/A/A0/user
usermod -d /mnt/pools/A/A0/user -m user
Login as this new user and edit .bashrc (or .profile) to incorporate /opt/bin into the path as described above.
Then, start transmission-daemon once, so that all the files and directories in .config/transmission-daemon are created:

Code: Select all

transmission-daemon -w /mnt/pools/A/A0/Downloads/
This also sets the path where downloads will be put in the settings file. Edit the settings file (after shutting down the daemon)

Code: Select all

vi .config/transmission-daemon/settings.json
to allow the web-access (see again above).
I also added an ssh-key for my user to be able to login without password prompt, and in particular to be able to start the daemon on the NAS in a local script just with the line

Code: Select all

ssh user@<NAS-IP> "transmission-daemon"
Anyone knows how to automatically start the daemon at system reboot?

cngdxd
Posts: 3
Joined: Sat Jun 18, 2011 8:37 am

Re: Transmission Working

Post by cngdxd » Thu Mar 22, 2012 4:44 am

always hangs if i use transmission

keeperX
Posts: 8
Joined: Sat Dec 24, 2011 4:09 am

Re: Transmission Working

Post by keeperX » Sat Apr 21, 2012 12:43 am

always hangs if i use transmission
I also suspect the hang is caused by transmission. Maybe there are software conflict?

aquamars
Posts: 6
Joined: Mon Mar 26, 2012 11:57 pm

Re: Transmission Working

Post by aquamars » Wed Feb 20, 2013 12:18 pm

Hey! Hello to an old post!

Is it possible to Update the daemon?
I've tryed "ipkg upgrade" etc, but no chance.

thanks,

Martin

ccie
Posts: 1
Joined: Sun Jun 30, 2013 8:43 pm

Re: Transmission Working

Post by ccie » Sun Jun 30, 2013 8:49 pm

After modifying the setting.jason at new location mnt/pools/A/A0/<Downloads>. Add following line to etc/rc.local to make settings persistence , and start transmission-daemon on startup.


/opt/bin/transmission-daemon -w /mnt/pools/A/A0/Downloads -g /mnt/pools/A/A0/Downloads

Post Reply