General NAS-Central Forums

Welcome to the NAS community
It is currently Mon May 29, 2017 5:00 pm

All times are UTC




Post new topic Reply to topic  [ 305 posts ]  Go to page 1, 2, 3, 4, 5 ... 21  Next
Author Message
PostPosted: Fri Aug 24, 2012 7:52 pm 
Offline

Joined: Fri Jul 13, 2012 8:12 am
Posts: 110
Dear all,

I am happy to announce the first version of OpenMediaVault (an open source NAS system) for the Home Media CE.

You can find all the details here: http://stefanseidel.info/component/cont ... cle/9.html

Discussion about specific features of and problem with OpenMediaVault can take place here: http://forums.openmediavault.org/viewto ... ?f=8&t=352

I'm open to any discussion and looking for feedback from brave users :)

Stefan


Top
 Profile  
 
PostPosted: Sun Aug 26, 2012 1:31 pm 
Offline

Joined: Sun Aug 26, 2012 11:11 am
Posts: 20
tks, it's work fine!

But can't set share folder of SMB and NFS service in web page, the Volume item not list out for select.


ex.Could you build kernel with usb sound card support for Home Media CE ?

Thanks


Top
 Profile  
 
PostPosted: Sun Aug 26, 2012 2:16 pm 
Offline

Joined: Fri Jul 13, 2012 8:12 am
Posts: 110
Hey, thanks for trying!!

I think you must first:
  • Go to the "Filesystems" page and select the only item and click "Mount".
  • Go to the "Shared Folder" page and add a new shared folder
Then you can make them visible via SMB/NFS etc.

Yes, I'm planning for a new kernel with more device support, e.g. USB audio and USB wireless LAN. Is there a particular software you have in mind to use for USB audio?

Stefan


Top
 Profile  
 
PostPosted: Sun Aug 26, 2012 2:31 pm 
Offline

Joined: Sun Aug 26, 2012 11:11 am
Posts: 20
Thank you again..

Usually use MPD & ALSA Device output


Top
 Profile  
 
PostPosted: Tue Aug 28, 2012 9:45 am 
Offline

Joined: Tue Sep 27, 2011 9:11 am
Posts: 38
Hi,
well done my friend. I have one of those devices and I think is good, but it has some limitations I'd like to remove. For instance, is a mess to configure an application to start at boot time. Before trying to install openmediavault I have some questions.
How likely is to lose data? I know you cannot guarantee that data will be 100% safe and I will backup the most important of them, but I have 1,2 TB of data, so a full backup is not possible.
Is very important to have a serial console attached to the device? I'm definitely not a "screw guy" and I'd prefer to avoid that.
The device has a registered copy of twonky media server installed. It is possible to maintain/restore it after the openmediavault is installed (or to use a free/open source media server)? I mainly use the device as a media tank so to me movie streaming is important.
Bye,
G


Top
 Profile  
 
PostPosted: Tue Aug 28, 2012 10:09 am 
Offline

Joined: Fri Jul 13, 2012 8:12 am
Posts: 110
buongiorgio wrote:
How likely is to lose data? I know you cannot guarantee that data will be 100% safe and I will backup the most important of them, but I have 1,2 TB of data, so a full backup is not possible.

Well, as with all operations you do to your hard disk, there is a chance that you'll loose the data. As I wrote earlier, if everything goes alright, then your data will be unharmed. In any case, the chance that you data will be lost completely is very low, just I don't want to give any warranties. Also, Iomega gives you the same warning if you upgrade their firmware!

buongiorgio wrote:
Is very important to have a serial console attached to the device? I'm definitely not a "screw guy" and I'd prefer to avoid that.

It's not essential. If you have your device updated to the current firmware and follow the guide exactly to the point, things should go smoothly. If you want to be extra safe, verify that the files on your USB stick are readable and were not corrupted while copying (e.g. by calculating the MD5 hash sum and comparing it to the originals: https://github.com/seidler2547/omv-arm/ ... ter/README )

buongiorgio wrote:
The device has a registered copy of twonky media server installed. It is possible to maintain/restore it after the openmediavault is installed (or to use a free/open source media server)? I mainly use the device as a media tank so to me movie streaming is important.

The original software will be lost. Maybe I'll look into the Twonky licence issue, should be possible to extract it since it will most likely be a static licence which is the same for all devices.

OMV has a media server called forked-daapd. You'll find more information here: http://www.technologeek.org/projects/daapd/index.html

Regards,

Stefan


Top
 Profile  
 
PostPosted: Thu Aug 30, 2012 12:22 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5995
Can you say anything about performance? Does it feel snappy? When googling around I found OpenMediaVault is officially only supported on x86/x64, which are no match for an arm.

I found this about installing on arm. The writer emphasizes a few times that it is slow. Now he uses a 400MHz INTEL XScale 80219, which is not the most powerful arm around. So I suppose a NAS 7820 will do much better, and I hope a Kirkwood will also.


Top
 Profile  
 
PostPosted: Thu Aug 30, 2012 12:35 pm 
Offline

Joined: Fri Jul 13, 2012 8:12 am
Posts: 110
I'm working with the main developer of OMV on the ARM support, also for the official repository - it's going forward and will soon be fully usable/installable even from plain Debian on ARM.

Performance is quite ok - I also read that on Pentium III people had to set the PHP timeout to 5 minutes to work it, but on the NAS7820 most pages render in less than 5 seconds. I wouldn't go as far as to say it's snappy, but it's definitely usable. Haven't tested file transfer/network performance yet, but I expect it to perform no better or worse than the original firmware.

I did have a problem when I tried to play ogg files on the device to a USB audio device using mpd, but that might have been a problem in mpd or the USB stack. mpd used 100% CPU when I tried and played at roughly 1/2 the original pace. Haven't tested much more up to now since I'm busy developing and fixing bugs (and other stuff) ;)

Stefan


Top
 Profile  
 
PostPosted: Fri Aug 31, 2012 3:15 pm 
Offline

Joined: Sun Aug 26, 2012 11:11 am
Posts: 20
Hi,Stefan

I use you contribute source code compiles out of a self-made kernel to support USB sound, Compilation succeeds and the device boots, Device is able to correctly identify the USB DAC.
When I after install ALSA and mpd, problems are as follows:
  • MPD generate media database had many serious errors, It cannot complete and correct recognized the media files;
  • Use ALSA aplay to play wav files, a CM103 USB DAC can normal speed playback and out loud, a PCM2705 USB DAC can only slow play and out noise;
  • mpd play FLAC files, used 100% CPU and slow playback noise.
I hope the above information will help you make the fix work.

Sorry for my English.

best regards


Top
 Profile  
 
PostPosted: Sun Sep 02, 2012 8:36 pm 
Offline

Joined: Thu Jul 28, 2011 11:34 pm
Posts: 5
Hi Stefan!

Thank you! I was looking for something like this for ages!

Installation: Totally smooth
Operation: Much faster the Iomega software!

Thanks again!
Krishna


Top
 Profile  
 
PostPosted: Tue Sep 04, 2012 9:44 pm 
Offline

Joined: Thu Jul 28, 2011 12:20 pm
Posts: 5
Hi Stefan.

Great work on this but I am having a few issues with my install.

Firstly I can't log in to root via SSH. I'm getting a few errors while trying to look at the update or plugins pages and I have to run a terminal command to manually fix this (or so OMV tells me) but when I try to log in as root via SSH my password doesn't work. I have tried 'openmediavault' and also my new admin password but neither work! Any ideas?

Also, after I have installed OMV, how would I re-install it to reset my system? Holding the reset button while powering on the drive no longer works. I imagine because OMV has overidden the basic hardware functions.

FYI I am a linux noob and have very little knowledge of linux commands. Any help you could offer would be greatly appreciated :)


Top
 Profile  
 
PostPosted: Wed Sep 05, 2012 9:19 am 
Offline

Joined: Fri Jul 13, 2012 8:12 am
Posts: 110
diem1000000 wrote:
Firstly I can't log in to root via SSH. I'm getting a few errors while trying to look at the update or plugins pages and I have to run a terminal command to manually fix this (or so OMV tells me) but when I try to log in as root via SSH my password doesn't work. I have tried 'openmediavault' and also my new admin password but neither work! Any ideas?

On my website I wrote that the root password is "root".

diem1000000 wrote:
Also, after I have installed OMV, how would I re-install it to reset my system? Holding the reset button while powering on the drive no longer works. I imagine because OMV has overidden the basic hardware functions.

On my website I also wrote how to get back to the stock firmware. You can use the same to reinstall OMV - execute
Code:
bash /boot/restore_fw.sh

and then you can shut down the system and use the button technique to reinstall OMV.

stefan


Top
 Profile  
 
PostPosted: Wed Sep 05, 2012 10:05 am 
Offline

Joined: Tue Sep 27, 2011 9:11 am
Posts: 38
Hi Stefan,
I'm going to install the OMV. On the prerequisutes list you wrote:

"definitely: a network router with DHCP enabled (it usually is) and the device connected to it (otherwise you won't be able to access the device)"

The router should be connected to the internet?

"ideally: a copy of the first 32MB of the hard drive in your device (for last-resort recovery)"

How can I make that copy? On the link provided there is a compressed file to be downloaded (http://downloads.iomega.nas-central.org ... 32M.img.gz) containing those 32 MB, so as far as I understood I have not to backup them from my own device.

Thank you


Top
 Profile  
 
PostPosted: Wed Sep 05, 2012 10:59 am 
Offline

Joined: Fri Jul 13, 2012 8:12 am
Posts: 110
buongiorgio wrote:
The router should be connected to the internet?

No, it's not required.

buongiorgio wrote:
"ideally: a copy of the first 32MB of the hard drive in your device (for last-resort recovery)"

How can I make that copy? On the link provided there is a compressed file to be downloaded (http://downloads.iomega.nas-central.org ... 32M.img.gz) containing those 32 MB, so as far as I understood I have not to backup them from my own device.

Yes, you can use the copy that I uploaded, the only minor thing is that the UUID will be different on your device. I don't think it is relevant for anything, though.
You can make your own copy when you log in via SSH and type
Code:
dd if=/dev/sda bs=1M count=32 of=/mnt/pools/A/A0/SharedFolderOfYourChoice/sda.img

and then you can copy the file "sda.img" from this SharedFolderOfYourChoice.

Stefan


Top
 Profile  
 
PostPosted: Wed Sep 05, 2012 11:35 am 
Offline

Joined: Thu Jul 28, 2011 12:20 pm
Posts: 5
Thanks for the reply Stefan.

I'll try what you have advised tonight and let you know how I get on.

Will the recovery/re-install method you've suggested wipe any of my data at all or will it just affect the 1st 32mb?

Thanks.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 305 posts ]  Go to page 1, 2, 3, 4, 5 ... 21  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group