Lacie CloudBox: DLNA without SRT support

Post Reply
Posts: 4
Joined: Sun Feb 16, 2014 11:16 pm

Lacie CloudBox: DLNA without SRT support

Post by vma » Sun Feb 16, 2014 11:42 pm


I bought a Lacie CloudBox today and to my surprise, the advertised "Multimedia Streaming" to Xbox360, PS3 and SmartTV is a joke, as the DLNA function does not support separate *.srt subtitle files. This renders the device totally useless for me and most people around the world.

I came here and followed the instructions to root the drive (worked on spot) and activate the Twonky setup page (success on the first attempt), but the installed v7 simply does not support SRT files.

Next, I followed the instructions to install "optware". This worked out, too. I can advice people not used to the "vi" editor to do "ipkg install nano" and then edit files with "nano filename".

Anyway, I then followed the instructions found on the wiki to download, compile and install miniDLNA, which does support the streaming of movie files with separate *.srt files. The downloading of all dependencies, gcc, make, etc., worked, but then I hit a wall as the "make" command would simply produce a "Sementation Fault". I have no clue why this happened!

Sadly, I did not found such a warning!

Has anyone had success in getting miniDLNA to compile and work?

...I am seriously considering returing this device.


Posts: 14
Joined: Fri Nov 22, 2013 11:21 pm

Re: Lacie CloudBox: DLNA without SRT support

Post by antieco » Mon Feb 17, 2014 11:20 am

Im interested on your idea, i need srt support.

Posts: 4
Joined: Sun Feb 16, 2014 11:16 pm

Re: Lacie CloudBox: DLNA without SRT support

Post by vma » Mon Feb 17, 2014 3:13 pm

What I did so far:

1) Get root access - follow this link: viewtopic.php?f=240&t=10725
2) Get Twonky Server Setup Webpage - follow this link: viewtopic.php?f=277&t=11913
3) Get "optware" - follow this link:
4) Install "nano" text editor (much easier to use than "vi"): ipkg install nano
5) Install "miniDLNA" - follow this link: ... ch_2011.29

"optware", as far as I understood, has the purpose of allowing to create a folder structure similar to /usr under /opt. This is requiered because /usr is in read only storage space. The problem with this is that many binaries have to be compiled so that they look for libraries in /opt/lib instead of /usr/lib. This is why you cannot simply use a precompiled "minidlna" binary (i.e. made for a WD NAS), because it will complain that it did not find the required libraries. This is because it looks for them in the wrong place.

Unfortunatly, the instructions on point 5) did not work, either, because I cannot execute the "make" command. It will produce a "Segmentation Fault". Any help would be appreciated! All other steps worked fine, which made this extra frustrating.


Posts: 1
Joined: Wed Feb 26, 2014 1:20 pm

Re: Lacie CloudBox: DLNA without SRT support

Post by claudioferreira » Wed Feb 26, 2014 1:27 pm

I just bought the Cloudbox HD and I'm getting video but no subtitles too. Both on a sony and LG smartv wich are 2013 models.
It's a real shame you had to go through all that (rooting etc) and still not get something that simple as subtitles to work.

The next week or so I'll try to follow your steps and will report my results here. Meanwhile it'd be really nice to hear from you or anyone who's trying of actually managed to fix that.
Also, does anyone know what Lacie says about that?

Thanks for sharing.

Posts: 1
Joined: Sun Sep 28, 2014 4:59 pm

Re: Lacie CloudBox: DLNA without SRT support

Post by vallausa » Sun Sep 28, 2014 5:08 pm

Hi there,

I have the same problem with a LaCie Cloudbox and an 2013 LG SmarTV. Did any one of you solved the problem?

I've visited forums of other NAS models (e.g. Synology) and everyone seems to have the same issue. Is there any way to fix this? Otherwise I might return the NAS.

Thanks a lot.

Posts: 2
Joined: Wed Oct 29, 2014 10:49 am

Re: Lacie CloudBox: DLNA without SRT support

Post by coupex » Wed Oct 29, 2014 10:53 am

I have not try to compile mini-dlna. I am very disappointed with Lacie, cannot understand how it is possible to happen. If any solution please report asap.

Thanks in advance.

Post Reply