Iomega EZ Media & Backup Center Install Transmission

spl51285
Posts: 7
Joined: Mon Mar 04, 2013 9:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by spl51285 » Tue Jun 18, 2013 4:55 pm

basa wrote:Its possible compile for iOmega Ez M&B older version Transmission 2.33 or 2.22 ? My torrent site not allow 2.77 :/ Or maybe compile 2.77 who will be visible for torrent site as 2.33 or 2.22 (little cheat :> )

thanx for great tutorial and reply for my request :)
You would have to find an Ipkg version of the 2.33 transmission to install it my way... i didnt find one...

You can try compiling it but that might take forever and you still have to find the source code for it... and some of the older versions have a lot of problems to run on this type of arm processor... i would stick with the 2.77.

spl51285
Posts: 7
Joined: Mon Mar 04, 2013 9:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by spl51285 » Tue Jun 18, 2013 5:06 pm

kimjj81 wrote:Hi.
I'm a newbie and encounted a problem.

I've installed transmission.
But when I connect via Web, I just can see belows.


409: Conflict

Your request had an invalid session-id header.

To fix this, follow these steps:

When reading a response, get its X-Transmission-Session-Id header and remember it
Add the updated header to your outgoing requests
When you get this 409 error message, resend your request with the updated header
This requirement has been added to help prevent CSRF attacks.


What should I do?

Thanks.

try using the following when accessing the transmission via web:

http://[yourhosturloripaddress]:9091/transmission/web/
the slash after web is important

also try this

http://[yourhosturloripaddress]:9091/transmission/web/#files

spl51285
Posts: 7
Joined: Mon Mar 04, 2013 9:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by spl51285 » Tue Jun 18, 2013 5:12 pm

pianzuo wrote:hello. my version is 4.0.2.9960. When i try to install bzip2, i found that:


//opt/ipkg/info/bzip2.postinst: line 2: /opt/bin/update-alternatives:

Can you tell me how to do it? Make a link ?


sorry but why do you want to install bzip2 ... i haven't installed bzip2 but i don't remember now why.... it could be that some programs don't install right ....install like i have it up there and it should work..

shadowcliffs
Posts: 21
Joined: Thu Aug 01, 2013 4:42 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by shadowcliffs » Thu Aug 01, 2013 5:27 am

It seems folder created by transmission is read only to everyone else. You have to log in as root and use following code to reset folder permission.

Code: Select all

chmod -R 777 Downloads
To make folders and files created by transmission r/w to everyone, change (after stopping transmission)

Code: Select all

"umask": 18, 
to

Code: Select all

"umask": 0,
spl51285 wrote:To install Tranmission on the Iomega EZ Media & Backup Center (from now on EZ)

----------[/color]

shadowcliffs
Posts: 21
Joined: Thu Aug 01, 2013 4:42 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by shadowcliffs » Fri Aug 02, 2013 7:31 pm

Are you sure this script works? It seems I can't get it to work. Any idea? I replaced the "/path/to" with "/opt/bin", and "/path/to/transmission args" with "/opt/bin/transmission-daemon --config-dir /mnt/pools/A/A0/Media/Downloads/_config", no luck.
Mijzelf wrote:The file /etc/rc.local is called on boot, writable and persistent. So you can use it to start your own stuff. Unfortunately the data partition is not yet mounted when it's called, so it will have to wait until the partition is mounted, and yet it has to finish to continue the boot process.

Code: Select all

#!/bin/sh

Polling()
{
    while [ true ] ; do
        if [ -x /path/to/transmission ] ; then
            /path/to/transmission  args
            exit 0
        fi
        sleep 10
    done
}

Polling &

exit 0
You can exchange rc.local by this script. It starts 'Polling' in background, and exits.
Polling waits until transmission is available, and starts it. Mission completed.

netoya
Posts: 1
Joined: Wed Aug 14, 2013 11:32 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by netoya » Wed Aug 14, 2013 11:56 am

There is a new and easy way to install transmission via web-interface. You firmware must be 4.0.2.9960 and higher.
Go to application manager in control panel and install this package http://www.filedropper.com/torrent02armel .

That's all, no need to use ssh. ;)

alex3xxx
Posts: 1
Joined: Fri Sep 20, 2013 5:38 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by alex3xxx » Fri Sep 20, 2013 6:01 am

Hi "http://www.filedropper.com/torrent02armel ." the link is dead. Could you please upload the file again, to somewhere else.

psp150
Posts: 2
Joined: Tue Sep 24, 2013 6:57 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by psp150 » Tue Sep 24, 2013 7:07 am

Thank you and It worked but the download speed is unstable in my Iomega EZ .

ggville
Posts: 5
Joined: Sat Sep 28, 2013 11:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by ggville » Sat Sep 28, 2013 11:48 pm

Hi,
please could you share that file once more - the link in filedropper "http://www.filedropper.com/torrent02armel " is not working.

thanks in advance

ggville
Posts: 5
Joined: Sat Sep 28, 2013 11:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by ggville » Mon Nov 11, 2013 3:31 am

spl51285 wrote:
pianzuo wrote:hello. my version is 4.0.2.9960. When i try to install bzip2, i found that:


//opt/ipkg/info/bzip2.postinst: line 2: /opt/bin/update-alternatives:

Can you tell me how to do it? Make a link ?


sorry but why do you want to install bzip2 ... i haven't installed bzip2 but i don't remember now why.... it could be that some programs don't install right ....install like i have it up there and it should work..
I also got this error and a couple of similar errors while installing Transmission - but just ignored them and it worked finally.

ggville
Posts: 5
Joined: Sat Sep 28, 2013 11:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by ggville » Mon Nov 11, 2013 3:32 am

shadowcliffs wrote:Are you sure this script works? It seems I can't get it to work. Any idea? I replaced the "/path/to" with "/opt/bin", and "/path/to/transmission args" with "/opt/bin/transmission-daemon --config-dir /mnt/pools/A/A0/Media/Downloads/_config", no luck.
Mijzelf wrote:The file /etc/rc.local is called on boot, writable and persistent. So you can use it to start your own stuff. Unfortunately the data partition is not yet mounted when it's called, so it will have to wait until the partition is mounted, and yet it has to finish to continue the boot process.

Code: Select all

#!/bin/sh

Polling()
{
    while [ true ] ; do
        if [ -x /path/to/transmission ] ; then
            /path/to/transmission  args
            exit 0
        fi
        sleep 10
    done
}

Polling &

exit 0
You can exchange rc.local by this script. It starts 'Polling' in background, and exits.
Polling waits until transmission is available, and starts it. Mission completed.

I modified it this way - hopefully should work when I reboot the NAS:

Code: Select all


Polling()
{
    while [ true ] ; do
        if [ -x /mnt/pools/A/A0/Media/Downloads/_config/settings.json ] ; then
            /opt/bin/transmission-daemon --config-dir /mnt/pools/A/A0/Media/Downloads/_config
            exit 0
        fi
        sleep 10
    done
}

Polling &

exit 0


Mijzelf
Posts: 6199
Joined: Mon Jun 16, 2008 10:45 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by Mijzelf » Mon Nov 11, 2013 9:39 am

That might work, but not necessarily. The [ -x file ] construction checks if a file is executable (has the 'executable ' flag set). Which transmission is, but a configuration file maybe not. In this case you could better use [ -e file ] , which simply checks if a file exists.

shadowcliffs
Posts: 21
Joined: Thu Aug 01, 2013 4:42 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by shadowcliffs » Mon Dec 02, 2013 10:40 am

This piece of script is still not working for me. Has it been working for you?
ggville wrote:
I modified it this way - hopefully should work when I reboot the NAS:

Code: Select all


Polling()
{
    while [ true ] ; do
        if [ -x /mnt/pools/A/A0/Media/Downloads/_config/settings.json ] ; then
            /opt/bin/transmission-daemon --config-dir /mnt/pools/A/A0/Media/Downloads/_config
            exit 0
        fi
        sleep 10
    done
}

Polling &

exit 0


ggville
Posts: 5
Joined: Sat Sep 28, 2013 11:43 pm

Re: Iomega EZ Media & Backup Center Install Transmission

Post by ggville » Thu Dec 05, 2013 8:13 pm

I haven't tested (restarted) it yet - but you may want to try as Mijzelf suggested - replace -x with -e.

shadowcliffs
Posts: 21
Joined: Thu Aug 01, 2013 4:42 am

Re: Iomega EZ Media & Backup Center Install Transmission

Post by shadowcliffs » Mon Dec 30, 2013 2:48 am

Transmission 2.77 (14031) is available on Firmware Version 4.0.6.19294. It will auto-start with the NAS once installed from the manage interface. But I haven't figured out how to change the default port (9091) yet.

Post Reply