General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Apr 28, 2017 3:56 pm

All times are UTC




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: Sun Jun 23, 2013 5:59 pm 
Offline

Joined: Sun May 19, 2013 2:52 am
Posts: 4
After following the instructions line for line to get Transmission installed (extremely happy about it), I am now wondering if I can add the last piece to the puzzle by adding Plex Media Server to the EZ Media. I have an Apple TV 3 (non-jailbreakable), and because there's a hacky way to make ATV3 see the Plex, I'm eager to figure this out.

I tried installing FFP, but I couldn't get slacker to install Plex (and I figured a lot of the instructions at the beginning weren't relevant since I already had SSH up and running).

Is there a way to install with ipkg?

Sorry for the noob-question and bare request. I just have been hitting my head against a wall for several hours trying to get Plex somehow installed.


Top
 Profile  
 
PostPosted: Mon Jun 24, 2013 7:59 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5981
Quote:
I tried installing FFP, but I couldn't get slacker to install Plex
Did FFP work? What did slacker do?


Top
 Profile  
 
PostPosted: Tue Jun 25, 2013 5:11 pm 
Offline

Joined: Sun May 19, 2013 2:52 am
Posts: 4
I installed it through the LenovoEMC Application Manager. It seemed to work -- installed a directory in the root directory and had a bunch of files.

However, I didn't exactly follow the instructions word-for-word for FFP. Instead, I used the regular built-in SSH / root to get to the command prompt. When I typed in "slacker" it just told me "-sh slacker: command not found."

I found slacker within the ffp folder, and I went to it and ran it using "./ slacker" and tried following the instructions for installing FFP, but it kept giving me errors.

Then, even trying to use ipkg was giving me errors, so I uninstalled FFP and have been searching around for another way.

Do you think FFP will work better if I use the FFP-built-in telnet?


Top
 Profile  
 
PostPosted: Tue Jun 25, 2013 7:17 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5981
shimbopper wrote:
Do you think FFP will work better if I use the FFP-built-in telnet?
It shouldn't matter. The FFP package patches /etc/passwd to change the shell for root and admin from /bin/sh to /ffp/bin/sh. This has as side effect that /ffp/etc/profile is called, which adds /ffp/bin and /ffp/sbin to the PATH.
The build in ssh and FFP telnet both read /etc/passwd, so it should work both.

But in your case slacker wasn't found, so I suppose somehow the PATH was wrong, and probably that means the patching of /etc/passwd failed. Running slacker by providing the absolute or relative path doesn't work, as slacker is not able to find it's tools.

Have a look at your /etc/passwd.


Top
 Profile  
 
PostPosted: Tue Jun 25, 2013 8:17 pm 
Offline

Joined: Sun May 19, 2013 2:52 am
Posts: 4
Ok, for some reason, FFP decided to work perfectly this time. I installed it -- stayed out of SSH while it was downloading/installing, and then logged in a few minutes later. Slacker magically worked. I did the following

Quote:
Code:
root@me:/# slacker -UaA mz:plex



Code:
root@me:/# chmod a+x /ffp/start/plexmediaserver.sh
root@me:/# /ffp/start/plexmediaserver.sh install

Installing Plex
--2013-06-25 16:10:10-- http://plex.r.worldssl.net/PlexMediaSer ... 6d-arm.spk
Resolving plex.r.worldssl.net... 69.65.41.240
Connecting to plex.r.worldssl.net|69.65.41.240|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 79332976 (76M) [application/octet-stream]
Saving to: `plexfile.gz'

100%[======================================>] 79,332,976 2.92M/s in 28s

2013-06-25 16:10:44 (2.73 MB/s) - `plexfile.gz' saved [79332976/79332976]

Synology package detected
Done


I'm following these instructions roughly, and I'll let you know when I get home later whether it works with my setup

viewtopic.php?f=249&t=7603


Top
 Profile  
 
PostPosted: Thu Nov 21, 2013 9:58 pm 
Offline

Joined: Thu Nov 21, 2013 9:56 pm
Posts: 2
Wow, followed a few links and didn't think I did it right, but low and behold it worked very easily, Thanks!!!just found my new favorite forum. GOT TO LOVE IT, Plex working strong on my EZ

UPDATE,

well it worked for about an hour then my drive drops off the network and cant see it anymore until I power cycle it and then its back up for a short while...not sure what to do now.


Top
 Profile  
 
PostPosted: Sat Nov 23, 2013 10:56 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5981
Can you ping it? Can you telnet or ssh in?


Top
 Profile  
 
PostPosted: Sun Nov 24, 2013 7:04 pm 
Offline

Joined: Thu Nov 21, 2013 9:56 pm
Posts: 2
when I cycle power on it, I have a window of like 5-10 minutes that it works fine, can access the plex web config page on it, can start a movie stream, can access network folders but after that it starts to act erratic and finally just slows to a crawl and times out on trying to connect

I can ping it, but when I tried to ssh in, the login just stood there for ever, It never said not able to connect, it just sat there.

I tried to stop plex but gave me error that it could not stop, something was wrong...

tried to uninstall it, it just said not able to something like permission denied..

I gave up and power cycled it, it gave me like 5 minutes to slooooowly make my way through the Lenovo Gui and hit the factory reset option, erased everything and started off clean, works now just fine, but don't think Im going to try putting Plex on it again, seemed to drag it down to the ground on processing power. maybe the 1T amount of videos I have on it? Or just not sure, maybe I did something wrong.


Top
 Profile  
 
PostPosted: Sun Nov 24, 2013 7:22 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5981
I must admit that I have no actual experience with Plex. It might be that your 1TB of video's is a problem, I guess Plex does some indexing?

Another problem could be that the EZ just doesn't have enough memory. When I remember well it has only 128MB, while the ZyXEL boxes on which it all is developed and tested have 256-512MB. I can imagine that some daemons seem to be down when the box is heavily swapping.


Top
 Profile  
 
PostPosted: Sat Jan 07, 2017 8:06 am 
Offline

Joined: Sat Jan 07, 2017 7:37 am
Posts: 2
I have NAS Iomega (Lenovo) IX2-200 with installed and working FFP, flex media server.

I want watch flex on Apple TV 3, but with the latest firmware you want to install PlexConnect and generate a certificate.

This command don't working on my NAS with FFP
Code:
# Installation
git clone https://github.com/iBaa/PlexConnect.git


Please help me setup and generate a certificate and it.

Sorry for my bad english. :oops:

UPDATE:
1. I'm copied PlexConnect to /ffp/bin/PlexConnect
2. Install mz:Phyton

Then I try start it.:
Code:
-sh: sudo: command not found
root@MyCloud:/ffp/bin/PlexConnect# sh ./PlexConnect.py
./PlexConnect.py: line 8:
PlexConnect

Sources:
inter-process-communication (queue): http://pymotw.com/2/multiprocessing/communication.html
: No such file or directory
./PlexConnect.py: line 11: import: command not found
from: can't read /var/mail/os
./PlexConnect.py: line 13: import: command not found
from: can't read /var/mail/multiprocessing
from: can't read /var/mail/multiprocessing.managers
./PlexConnect.py: line 16: import: command not found
from: can't read /var/mail/Version
./PlexConnect.py: line 19: import: command not found
./PlexConnect.py: line 20: import: command not found
from: can't read /var/mail/PILBackgrounds
from: can't read /var/mail/Debug
./PlexConnect.py: line 26: syntax error near unexpected token `('
./PlexConnect.py: line 26: `def getIP_self():'


Top
 Profile  
 
PostPosted: Mon Jan 09, 2017 8:01 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2218
Here are instructions step by step. If you are getting error or unexpected output on any step, then stop and report it.
Remove your copied plexconnect first:
Code:
rm /ffp/bin/PlexConnect

Then install slapt-get package manager and upgrade core packages:
Code:
[ -d /ffp/funpkg/cache/br2 ] || mkdir -p /ffp/funpkg/cache/br2
cd /ffp/funpkg/cache/br2
wget -nv http://downloads.zyxel.nas-central.org/Users/barmalej2/ffp/0.7/arm/packages/slapt-get-0.10.2t-arm-2.txz
funpkg -i slapt-get-0.10.2t-arm-2.txz
slapt-get -u
slapt-get --upgrade

Press y to confirm.
After upgrading restart sshd service:
Code:
sh /ffp/start/sshd.sh restart

Install/upgrade git and python:
Code:
slapt-get -i git python

Clone plexconnect to appropriate directory according to FHS rules:
Code:
cd /ffp/var/lib
git clone https://github.com/iBaa/PlexConnect.git
cd PlexConnect/assets/certificates

Now generate certificates:
Code:
openssl req -new -nodes -newkey rsa:2048 -out trailers.pem -keyout trailers.key -x509 -days 365 -subj "/C=US/CN=trailers.apple.com"
openssl x509 -in trailers.pem -outform der -out trailers.cer && cat trailers.key >> trailers.pem

Go back to main plexconnect dir:
Code:
cd /ffp/var/lib/PlexConnect

Now edit Settings.py file and change the ports (80 and 443 most likely are used by box already):
Quote:
('port_webserver' , ('8000', '[0-9]{1,5}')),
('port_ssl' , ('8443', '[0-9]{1,5}')),

Lastly start plexconnect service:
Code:
python ./PlexConnect.py

To stop service press CTRL+C.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group