NSA212 Package Lockout [No packages displaying]

Post Reply
Posts: 1
Joined: Thu Apr 02, 2015 1:13 pm

NSA212 Package Lockout [No packages displaying]

Post by Gantic » Thu Apr 02, 2015 1:44 pm

Hey guys! My name is James. Before I begin I just want to personally thank Mijzelf for his/her years of contribution to this development. You have made me get the absolute most out of my cheap aldi product and those guides cover everything I could have encountered, you've even documented my problem; the thing is though, I don't know how to fix it!

AND my problem is as follows.
The package manager in the web browser is no longer displaying packages at all due to the uninstallation of several packages. I don't have the PKG file to fix it as one of the packages I uninstalled was MetaRepository (which generates the file).
You can find a clearer explanation of my problem here, under the buggy sub header, mine is the worse case scenario.

Things I've tried: Removing the places where the packages could have been. alas, to no avail. And of course I've tried resetting to factory conditions. Can't really think of much else here, so I'll try anything! :shock:
I feel like a direct image flash would fix this easily yet it's next to impossible to get my hands on one.


Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: NSA212 Package Lockout [No packages displaying]

Post by Mijzelf » Fri Apr 03, 2015 8:11 pm

You see an empty page if the internal database contains packages which are not available in the current PKGS file. So the remedy is to either create a custom PKGS file, or cleanup your internal database.
The internal database can be found in /usr/local/zy-pkgs/zypkg_conf/. It consist of a 'status' file, and a subdirectory 'info'

Post Reply