General NAS-Central Forums

Welcome to the NAS community
It is currently Fri Jun 23, 2017 6:46 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Reimage ix2-dl
PostPosted: Fri Jan 23, 2015 4:12 am 
Offline

Joined: Thu Jan 09, 2014 1:48 am
Posts: 9
I tried to do a factory reset of my ix2-dl from the web gui. Everything seemed to work properly and the unit shut off (I can only assume the reset was complete at this point). However, now it won't startup and I can't access the web gui. When I turn on the unit the power indicator has a white light that stays solid for about a minute then it goes into blink mode and stays there forever. During this sequence I can see from my router status page that it gets assigned an IP address but this is only temporary and the device drops the connection.

I'm convinced my only option is to reimage the firmware. In several hours of web searching I've found some description on how to do this but cannot find detailed instructions. I've tried a handful of things with mixed results but no success. Can somebody provide some detailed instructions on how to reimage the firmware and provide any necessary files such as bootloaders? Any help is appreciated. Thanks.


Top
 Profile  
 
 Post subject: Re: Reimage ix2-dl
PostPosted: Fri Jan 23, 2015 8:43 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5996
Does this help?


Top
 Profile  
 
 Post subject: Re: Reimage ix2-dl
PostPosted: Mon Jan 26, 2015 2:36 pm 
Offline

Joined: Thu Jan 09, 2014 1:48 am
Posts: 9
Yes! I have brought my NAS back to life! Thanks Mijzelf for the help!

I followed the instructions at http://iomega.nas-central.org/wiki/Cate ... 0-usb-init. I used firmware ix2-ng-4.1.106.31982.tgz from Lenovo's site. And from the instructions page I used the second script: mkix2fw2usb. The only changes I made to the script were the name of the firmware file (obviously), the destination path 'ix2-200d_images' was changed to 'ix2-ng_images', and I changed the usb path to my machine's usb.

I had to use a linux machine to run the commands. Cygwin did not work because the mount command in cygwin is stripped down and doesn't have the loop option.


Top
 Profile  
 
 Post subject: Re: Reimage ix2-dl
PostPosted: Mon Jan 26, 2015 5:28 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5996
Glad you sorted it. :)

phill1127 wrote:
Cygwin did not work because the mount command in cygwin is stripped down and doesn't have the loop option.

Actually it's not Cygwin mount which is stripped down. The mount binary only tells the kernel what to do. It is the Windows kernel which is stripped down. It only supports a very limited number of filesystems, and no loopmount.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group