Install custom software on PX4-300D

seidler2547
Posts: 110
Joined: Fri Jul 13, 2012 8:12 am

Re: Install custom software on PX4-300D

Post by seidler2547 » Mon Feb 11, 2013 11:03 pm

Yes run the mount command but append .ungz to initrd.

And after umount ir at the end, do gzip -c < initrd.ungz > initrd

Stefan

edwardmp
Posts: 16
Joined: Thu Jan 31, 2013 9:46 pm

Re: Install custom software on PX4-300D

Post by edwardmp » Mon Feb 11, 2013 11:30 pm

Okay, got a little further with that.

Not enough space only..
root@NAS:/mnt/apps# tar c * | tar x -C /boot/images/an
tar: usr/local/samba/bin/smbtree: Wrote only 2560 of 10240 bytes
tar: usr/local/samba/bin/tdbbackup: Cannot write: No space left on device
tar: usr/local/samba/bin/tdbdump: Cannot write: No space left on device
tar: usr/local/samba/bin/tdbtool: Cannot write: No space left on device
tar: usr/local/samba/bin/testparm: Cannot write: No space left on device
tar: usr/local/samba/bin/wbinfo: Cannot write: No space left on device
tar: usr/local/samba/include: Cannot mkdir: No space left on device
tar: usr/local/samba/lib: Cannot mkdir: No space left on device
tar: usr/local/samba/lib/auth: Cannot mkdir: No such file or directory
tar: usr/local/samba/lib/auth/script.so: Cannot open: No such file or directory
tar: usr/local/samba/lib/charset: Cannot mkdir: No such file or directory
tar: usr/local/samba/lib/charset/CP437.so: Cannot open: No such file or directory
tar: usr/local/samba/lib/charset/CP850.so: Cannot open: No such file or directory
tar: usr/local/samba/lib/de.msg: Cannot open: No such file or directory
tar: usr/local/samba/lib/en.msg: Cannot open: No such file or directory
tar: usr/local/samba/lib/fi.msg: Cannot open: No such file or directory
tar: usr/local/samba/lib/fr.msg: Cannot open: No such file or directory
tar: usr/local/samba/lib/gpext: Cannot mkdir: No such file or directory
tar: usr/local/samba/lib/idmap: Cannot mkdir: No such file or directory
tar: usr/local/samba/lib/it.msg: Cannot open: No such file or directory
tar: usr/local/samba/lib/ja.msg: Cannot open: No such file or directory
tar: usr/local/samba/lib/libnetapi.so: Cannot create symlink to `libnetapi.so.0': No such file or directory
tar: usr/local/samba/lib/libnetapi.so.0: Cannot open: No such file or directory
tar: usr/local/samba/lib/libsmbclient.so: Cannot create symlink to `libsmbclient.so.0': No such file or directory
tar: usr/local/samba/lib/libsmbclient.so.0: Cannot open: No such file or directory
tar: usr/local/samba/lib/libsmbsharemodes.so: Cannot create symlink to `libsmbsharemodes.so.0': No such file or directory
tar: usr/local/samba/lib/libsmbsharemodes.so.0: Cannot open: No such file or directory
tar: usr/local/samba/lib/libtalloc.so: Cannot create symlink to `libtalloc.so.2': No such file or directory
This is just the beginning of the output but you get the idea.

df -h outputs this:
root@NAS:/mnt/apps# df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 50M 3.2M 47M 7% /
/dev/root.old 6.5M 3.0M 3.6M 46% /initrd
none 50M 3.2M 47M 7% /
/dev/sde1 941M 753M 140M 85% /boot
/dev/loop0 217M 217M 0 100% /mnt/apps
/dev/loop1 7.5M 2.3M 4.9M 32% /etc
/dev/loop2 1.9M 1.9M 0 100% /oem
tmpfs 998M 0 998M 0% /mnt/apps/lib/init/rw
tmpfs 998M 0 998M 0% /dev/shm
/dev/mapper/6ecd3c42_vg-vol1
20G 1.1G 19G 6% /mnt/system
/dev/mapper/77d75ef1_vg-lv34398f64
2.7T 557G 2.1T 21% /mnt/pools/A/A0
/dev/loop3 6.5M 4.1M 2.4M 64% /boot/images/ir
/dev/loop4 504M 504M 0 100% /boot/images/an

seidler2547
Posts: 110
Joined: Fri Jul 13, 2012 8:12 am

Re: Install custom software on PX4-300D

Post by seidler2547 » Tue Feb 12, 2013 7:50 am

Alright, seems like there is a link somewhere or just really not enough space.

First, roll back:

Code: Select all

cd /boot/images
umount an
losetup -d /dev/loop4
rm -Rf apps.new
Before you continue, check how big the apps image really is:

Code: Select all

du -hcsx /mnt/apps/*
If the last line (total) says it's bigger than 630M, then it's problematic, since there's not more space on the boot device. If it's smaller, do this:

Now repeat all the steps for converting the squashfs images but with some small modifications:

Code: Select all

cd /boot/images
dd if=/dev/zero of=apps.new bs=1M seek=629 count=1 # make a bigger sparse image for the new r/w apps
mkfs.ext2 -F -m 0 apps.new # format it as ext2
mkdir an
mknod /dev/loop4 b 7 4 # don't worry if this yields an error
mount -o loop apps.new an
cd /mnt/apps
tar c --one-file-system * | tar x -C /boot/images/an # can take a while
cd -
ls an # this should output a couple of folders like bin, lib, usr, var
umount an
and continue from there with my original instructions. Remember that if everything went fine, at the end, after umount ir you do

Code: Select all

gzip -c < initrd.ungz > initrd
which is the only really "dangerous" command (it will put in effect all you've done up to then), since you must only execute it when everything above went well.

Stefan

edwardmp
Posts: 16
Joined: Thu Jan 31, 2013 9:46 pm

Re: Install custom software on PX4-300D

Post by edwardmp » Tue Feb 12, 2013 2:19 pm

Damn, its 638 MB..
root@NAS:/boot/images# du -hcsx /mnt/apps/*
4.2M /mnt/apps/bin
0 /mnt/apps/dev
1.5M /mnt/apps/etc
0 /mnt/apps/include
15M /mnt/apps/lib
60M /mnt/apps/lib64
0 /mnt/apps/mnt
0 /mnt/apps/proc
2.0M /mnt/apps/ram
9.4M /mnt/apps/sbin
191K /mnt/apps/share
0 /mnt/apps/sys
6.1M /mnt/apps/tmp
541M /mnt/apps/usr
0 /mnt/apps/var
638M total
Really appreciate your help!

seidler2547
Posts: 110
Joined: Fri Jul 13, 2012 8:12 am

Re: Install custom software on PX4-300D

Post by seidler2547 » Tue Feb 12, 2013 2:41 pm

Hm! So another idea: unionfs. Can you pastebin ls -lR /lib/modules/$(uname -r) ?

Stefan

edwardmp
Posts: 16
Joined: Thu Jan 31, 2013 9:46 pm

Re: Install custom software on PX4-300D

Post by edwardmp » Tue Feb 12, 2013 10:36 pm


seidler2547
Posts: 110
Joined: Fri Jul 13, 2012 8:12 am

Re: Install custom software on PX4-300D

Post by seidler2547 » Tue Feb 12, 2013 10:36 pm

And in the end, (not to sound too negative here), it might be easier, (but riskier, I admit), to install a plain Debian Squeeze or Wheezy and something like OpenMediaVault. Then you'll get rid of the whole Iomega software stuff and just be done with it.

Stefan

edwardmp
Posts: 16
Joined: Thu Jan 31, 2013 9:46 pm

Re: Install custom software on PX4-300D

Post by edwardmp » Tue Feb 12, 2013 10:38 pm

Maybe you are right, but I don't know if everything will work OK on MediaVault etc.
I don't want to brick my NAS. Since it has no screen, if any reinstallation fails you are fucked.

Only if what we're doing right now yields no results, which I doubt.

edwardmp
Posts: 16
Joined: Thu Jan 31, 2013 9:46 pm

Re: Install custom software on PX4-300D

Post by edwardmp » Fri Feb 15, 2013 11:27 pm

New problem: the NAS suddenly crashed (didn't do anything)

NAS was automatically "restructuring data". It was hanging for more than 24 hours on 1 percent. Rebooted it, storage pool could not be found.
Rebooted again, this time it restructured data again, and it worked. Storage pool and files were accessible, but it displayed it was still rebuilding the NAS.
I left it for a few hours, then the load became so high (>10) that the NAS was inacessible trough SSH and web.
After hours with no improvement, had to reboot it again. Now the device every time messages something else.
Storage pool not found, after reboot it is found and I See shares, but no data.

In /proc/mdstat I've seen both resync and recovery. Recovery keeps hanging everytime.

It now looks like this
cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath] [faulty]
md1 : active raid5 sdd2[0] sda2[3] sdb2[2] sdc2[1]
2867343360 blocks super 1.0 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]
[=>...................] resync = 5.0% (48396580/955781120) finish=322.1min speed=46943K/sec

md0 : active raid1 sda1[0] sdd1[3] sdc1[2] sdb1[1]
20980816 blocks super 1.0 [4/4] [UUUU]

unused devices: <none>
root@NAS:/var/log# df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 50M 3.1M 47M 7% /
/dev/root.old 6.5M 3.0M 3.6M 46% /initrd
none 50M 3.1M 47M 7% /
/dev/sde1 941M 241M 652M 27% /boot
/dev/loop0 217M 217M 0 100% /mnt/apps
/dev/loop1 7.5M 2.3M 4.9M 32% /etc
/dev/loop2 1.9M 1.9M 0 100% /oem
tmpfs 998M 0 998M 0% /mnt/apps/lib/init/rw
tmpfs 998M 0 998M 0% /dev/shm
/dev/mapper/6ecd3c42_vg-vol1
20G 1.1G 19G 6% /mnt/system
Here I don't see the 4TB disks?? This is really strange.

Iomega product really suck, even this 1000+ Euro machine isn't reliable at all, even when it runs in Raid-5. No normal users without too much technical knowledge could restore this. Me, having a only very basic linux experience, can't figure this out. Data is probably lost. Not too important, but still a bummer. Gonna dump this NAS in the trash and buy another brand I think

edwardmp
Posts: 16
Joined: Thu Jan 31, 2013 9:46 pm

Re: Install custom software on PX4-300D

Post by edwardmp » Wed Apr 03, 2013 2:23 am

Yo Seidler, you still here?

User avatar
Scramble
Posts: 3
Joined: Wed Sep 11, 2013 11:38 am

Re: Install custom software on PX4-300D

Post by Scramble » Tue Oct 01, 2013 1:27 am

Got ipkg working on my ix4, read viewtopic.php?f=41&t=11473
px series uses intel atom but the same should apply if you download the program for that processor.
Might try this instead.

Code: Select all

wget http://ipkg.nslu2-linux.org/feeds/optware/syno-i686/cross/unstable/ipkg-opt_0.99.163-10_i686.ipk
tar -xOvzf ipkg-opt_0.99.163-10_i686.ipk ./data.tar.gz | tar -C / -xzvf -
mkdir -p /opt/etc/ipkg
echo "src cross http://ipkg.nslu2-linux.org/feeds/optware/syno-i686/cross/unstable" >> /opt/etc/ipkg/cross-feed.conf
echo "src native http://ipkg.nslu2-linux.org/feeds/optware/syno-i686/cross/unstable" >> /opt/etc/ipkg/cross-feed.conf
rm ipkg-opt_0.99.163-10_i686.ipk
/opt/bin/ipkg update
Not 100% sure about the filename for the conf file though, might be /opt/etc/ipkg.conf, syno-i686-feed.conf, or something else. Anyway it is cetainly worth trying.
Iomega StorCenter ix4-300d
Instantly get 20GB of cloud storage https://copy.com?r=gvPfNQ

superdupe
Posts: 2
Joined: Sun Mar 16, 2014 11:41 pm

Re: Install custom software on PX4-300D

Post by superdupe » Sun Mar 16, 2014 11:50 pm

Has anyone worked anymore on this? I'm trying to add pyTivo to my px4 to make it a TiVo video server... I tried Scramble's solution for the ix4, but when I try to do the ipkg update, I get "cannot execute binary file" response. I'm not much of a unix/Linux person so bear with me... But I'm guessing in the updates made to the px4 vs the ix4 some parts of the os were locked down? Any help would be appreciated... Thanks! :)

skamristo
Posts: 1
Joined: Thu Oct 16, 2014 10:58 am

Re: Install custom software on PX4-300D

Post by skamristo » Thu Oct 16, 2014 11:00 am

i know only one way: reinstall OS
for example: Debian
You do not have the required permissions to view the files attached to this post.

danijoint
Posts: 1
Joined: Sun Oct 25, 2015 7:09 pm

Re: Install custom software on PX4-300D

Post by danijoint » Tue Oct 27, 2015 8:18 am

How can anybody tell me how to reinstall the firmware or OS again in the px4-300d?

My 2 px4-300d stucked at 75% after update the firmware :(

Post Reply