NAS 520 mySQL Issue

Mindspeed Comcerto 2000 based
Post Reply
bman4506
Posts: 3
Joined: Sat Sep 10, 2016 12:51 am

NAS 520 mySQL Issue

Post by bman4506 » Sat Sep 10, 2016 12:58 am

Hi All,

Out of the box my NAS was shipped with the initial 5.04 firmware. On 5.04 I added the myPHPAdmin package and got mySQL up and running. Could connect from a network device and read / write to the DB. I got a notification to upgrade to 5.11 and did so. Once I upgraded, was instructed to also upgrade the myPHPAdmin package version 006.

Once I upgraded the myPHPAdmin I was no longer able to read / write to the mySQL DB. I tried removing and re-installing to no avail. A number of forms state that my.cnf must be modified to allow network connections (change bind-address to 0.0.0.0), however, I am unable to locate the file.

Have been pulling my hair out. Any help would be greatly appreciated.

Thanks!

Mijzelf
Posts: 6226
Joined: Mon Jun 16, 2008 10:45 am

Re: NAS 520 mySQL Issue

Post by Mijzelf » Sat Sep 10, 2016 7:16 am

You can find that package (and it's configuration files) in /i-data/sysvol/.PKG/MySQL-phpMyAdmin/ (I doubt the exact spelling of the last term)

bman4506
Posts: 3
Joined: Sat Sep 10, 2016 12:51 am

Re: NAS 520 mySQL Issue

Post by bman4506 » Sat Sep 10, 2016 1:23 pm

Appreciate the reply. I just checked and don't see my.cnf. Looks like there are some reference files below in /i-data/sysvol/.PKG/PHP-MySQL-phpMyAdmin/mysql/share/mysql. Would I have to pull a reference file and rename? Not sure where to dump it either.

Thanks!

bman4506
Posts: 3
Joined: Sat Sep 10, 2016 12:51 am

Re: NAS 520 mySQL Issue

Post by bman4506 » Sat Sep 10, 2016 2:44 pm

Was looking around the net for a solution and found a forum in German (http://www.kodinerds.net/index.php/Thre ... SQL-Daten/). Turns out, a security enhancement was made on the mySQL side which only allows access to the DB from local host. I am running the DB for a Kodi / XBMC setup for a centralized library so that doesn't work out so well. Here is what I ended up having to do with 1.0zypkg006 PHP-MySQL-phpMyAdmin package already installed. Firmware version V5.11(AASZ.3). I also confirmed that this is an issue with 5.10 firmware. Initial 5.04 firmware is OK.

- Remove the 1.0zypkg006 PHP-MySQL-phpMyAdmin package. Click Uninstall / Cancel Installation to do so.
- Once uninstalled, click Install / Upgrade. IMPORTANT: Remove the check to activate the package once installed.
- Enable Telnet / SSH service from the control panel on the main Zyxel splash screen. This will not work with Chrome. Use Intenet Explorer.
- Open WinSCP. Connect to NAS520 / NAS540 (or whatever you changed hostname to). Username is root and password is whatever you set initially.
- On right pane, navigate to i-data/sysvol/. In bottom right it should say 3 hidden. Make sure to click this to view hidden files.
- Navigate to .PKG/PHP-MySQL-phpMyAdmin/etc/init.d
- Double-click PHP-MySQL-phpMyAdmin to open editor.
- Search for --bind-address
- Modify value from --bind-address=127.0.0.1 to --bind-address=0.0.0.0
- Click save icon in top left
- Navigate back to packages. For PHP-MySQL-phpMyAdmin package, click enable (looks like play button)

That should take care of it.

The only other thing you need to do is create a user account. You can do this from phpmyadmin http://nas520:5000/pkg/phpmyadmin/ page.
- Click users
- Click add user
- Username = KODI
- Leave host set to any host (%)
- Password is KODI
- Select Grant all privileges on wildcard name (username\_%).
- Select Global privileges Check All
- Click Go in bottom right.

Need to also modify your advancedsettings.xml file with username, password, and port information for mySQL. Default port is 3306.

Hope that helps anyone else that was struggling like I was.

Post Reply