General NAS-Central Forums

Welcome to the NAS community
It is currently Sat Apr 29, 2017 1:46 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Wed Sep 21, 2016 1:41 pm 
Offline

Joined: Sun Nov 07, 2010 7:16 pm
Posts: 15
Location: New Jersey
Hello...

I thought this might be of interest for some more...but i cannot tell if it works also on newer once...
viewtopic.php?f=249&t=18631
If yes...would be great...
On my NSA320 it works just great...
I need to know if the new once come with apcupsd and the other files i am mentioning...
THX!!!

_________________
NSA 320 with FFP and Metarepository on 4.7 firmware


Top
 Profile  
 
PostPosted: Wed Sep 21, 2016 5:39 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 5981
I live in an urban area with a rock-solid electricity supply. My server has currently an uptime of 500 days, without UPS. So I don't have an UPS and can't test it.

Yet I can tell you that firmware 5.20 on my NAS520 has /usr/sbin/apcupsd, /etc/init.d/apcupsd and /etc/apcupsd/apcupsd.conf (and some more files in the latter directory), and it hasn't a /etc/defaults directory. (Sounds very Debian, BTW, and nor the startscript nor the configuration points to it, so I don't think it matters if it's there or not)

In your directions you don't tell the /etc/apcupsd/ directory is reverted on each boot. How did you solve that?


Top
 Profile  
 
PostPosted: Wed Sep 21, 2016 6:23 pm 
Offline

Joined: Sun Nov 07, 2010 7:16 pm
Posts: 15
Location: New Jersey
Oh shoot...
I forgot that to put it into the instructions...
Of course you need these files on the NAS somewhere...i have them on the data volume...and on reboot i create a symlink to the folders
It is pretty common task in Freetz where i am home...smile
Cron job is needed and than this here: @reboot sleep 60 && my_script.sh
In the script you can either copy the files over and restart apcupsd or create the symlinks and restart the apcupsd...
But if someone would come up with an idea how to run scripts on boot + n seconds delay, that would help a lot.
Will update my Instruction to reflect this as well...

_________________
NSA 320 with FFP and Metarepository on 4.7 firmware


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group