General NAS-Central Forums

Welcome to the NAS community
It is currently Sat Dec 16, 2017 7:22 am

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Sep 29, 2017 12:47 pm 
Offline
User avatar

Joined: Fri Sep 29, 2017 10:38 am
Posts: 3
Location: Hamburg, Germany
On my Zyxel NAS542 (firmware version V5.21 (ABAG.0)) the MetaRepository does not work properly.

I installed it as described here. Now I have a big blue "MR" icon on the start page, when I click on it I got redirected to http://nasip:5000/pkg/MetaRepository/pkgcgi.cgi which is a simple blue page as shown in the screenshots here: http://zyxel.nas-central.org/wiki/File: ... nshot6.png

But that page looks like in the screenshot. There are no "modules" or config items, just a long changelog below. If I click on "Apply" it does not change. What went wrong? How can I fix it?

(I also asked in the Wiki, but the Wiki seems to be quite inactive)


Top
 Profile  
 
PostPosted: Sat Sep 30, 2017 10:01 am 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6091
RokerHRO wrote:
But that page looks like in the screenshot. There are no "modules" or config items, just a long changelog below.
If I click on "Apply" it does not change. What went wrong? How can I fix it?
It's not clear what you are trying to describe. What do you mean with 'no modules'?
The page is supposed to look like that screenshot, and 'Apply' doesn't change anything. If you want to install additional packages using MR, you'll have to use the 'App Center' applet. Go to 'Browse->All Apps', and press the cycle icon to refresh the package list.
The power of MR is that it automagically merges the ZyXEL package repository with one or more 3th party repo's.

Quote:
(I also asked in the Wiki, but the Wiki seems to be quite inactive)
The Wiki is intended for documentation, not for help.


Top
 Profile  
 
PostPosted: Sat Sep 30, 2017 12:51 pm 
Offline
User avatar

Joined: Fri Sep 29, 2017 10:38 am
Posts: 3
Location: Hamburg, Germany
Thanks for your quick answer.

Mijzelf wrote:
RokerHRO wrote:
But that page looks like in the screenshot. There are no "modules" or config items, just a long changelog below.
If I click on "Apply" it does not change. What went wrong? How can I fix it?
It's not clear what you are trying to describe. What do you mean with 'no modules'?


The Wiki page describes a lot of "modules" (or "tweaks" as they are named on the wiki page): Cron, FTP Daemon, Change Homedir, etc. On the wiki page are also many screenshots, which all have the blue design I also see when I click on the "MetaRepository" MR icon.

But I don't have all these modules (or "tweaks") on my blue "MetaRepository" page.

And the Wiki page does not describe how I can get them. :-( That's why I asked on the discussion page because the documentation seems to be incomplete here for a novice like me:

http://zyxel.nas-central.org/wiki/Talk:3rd_party_zypkgs

Quote:
The page is supposed to look like that screenshot, and 'Apply' doesn't change anything. If you want to install additional packages using MR, you'll have to use the 'App Center' applet. Go to 'Browse->All Apps', and press the cycle icon to refresh the package list.


When I go to "Browse -> All apps" I only see the usual Apps I already saw when I booted my NAS first time: "Dropbox Client", "GoogleDrive Client", "Logitech Media Server", "Wordpress", "NFS" and some more. All of them I already had before.

So I guess something does not work here as expected. :-(


Top
 Profile  
 
PostPosted: Sat Sep 30, 2017 6:03 pm 
Offline

Joined: Mon Jun 16, 2008 10:45 am
Posts: 6091
RokerHRO wrote:
The Wiki page describes a lot of "modules" (or "tweaks" as they are named on the wiki page): Cron, FTP Daemon, Change Homedir, etc. On the wiki page are also many screenshots, which all have the blue design I also see when I click on the "MetaRepository" MR icon.

But I don't have all these modules (or "tweaks") on my blue "MetaRepository" page.
Tweaks is a separate package, which nothing has to do with MR, except that you need MR to install Tweaks. The reason that they have the same blue design is because they are written by the same person.
Quote:
Quote:
Go to 'Browse->All Apps', and press the cycle icon to refresh the package list.


When I go to "Browse -> All apps" I only see the usual Apps
You have to press the cycle icon, which will cause the firmware package manager to download a new list of available packages. But this time MR will intercept it and inject the 3th party packages.


Top
 Profile  
 
PostPosted: Sat Sep 30, 2017 8:29 pm 
Offline
User avatar

Joined: Fri Sep 29, 2017 10:38 am
Posts: 3
Location: Hamburg, Germany
Long story short:

I added the "web_prefix" file again and clicked several times on the Reload icon in the "Available Apps" window (I got always an error message "Download failed", so I tried again and again).

After some failed reloads I found a different software / app selection that also had "RandomTools" and "Tweaks" which I have installed now.

Thank you!

But I still think the Wiki page does not describe this process properly. ;-(

L.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group