General NAS-Central Forums

Welcome to the NAS community
It is currently Tue Dec 12, 2017 9:47 pm

All times are UTC




Post new topic Reply to topic  [ 213 posts ]  Go to page Previous  1 ... 8, 9, 10, 11, 12, 13, 14, 15  Next
Author Message
PostPosted: Sun Mar 27, 2016 5:14 pm 
Offline

Joined: Sun Oct 05, 2014 10:05 am
Posts: 8
MrDini wrote:
Run:

Code:
slacker -a miniupnpc


And select one at the list.


Awesome! Thank you very much. I also had to install rtmp after that using the same method.


Top
 Profile  
 
PostPosted: Fri Jul 29, 2016 11:01 am 
Offline

Joined: Mon Sep 28, 2015 10:57 am
Posts: 1
I dont get any packes to install when i try to find miniupnpc or rtmp?

Witch repo have them? :)

*Edit
Fix it self by create my own packages from scratch by download the orginal file form transmission and used the howto and post 1.


Top
 Profile  
 
PostPosted: Mon Oct 10, 2016 11:45 am 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Hi.
I wanted to install Tranasmission 2.92, so I started as barmalej2 wrote.
I've done steps 1 and 2 from tutorial at the tof of this topic, but I had to do this manualy lib by lib.
Then I wanted to make a shortcut, and I figured, that I use MrDinis compilation.
So I've downloaded the package and I've put it into root.
Than I ran it and the outcome is:
Quote:
root@nsa310:~# funpkg -i Transmission-2.92-arm-2.txz
Scanning Transmission-2.92-arm-2.txz ...
#
# Transmission is a cross-platform and open-source BitTorrent client.
#
# Version: 2.92 (14714)
# Homepage: https://www.transmissionbt.com/
#
# Compiled by: Mr Dini
Installing Transmission-2.92-arm-2
root@nsa310:~#

Then I tryed to start it
Quote:
root@nsa310:~# /ffp/start/transmission.sh start
-sh: /ffp/start/transmission.sh: Permission denied

So I removed it
Quote:
funpkg -r Transmission-2.92-arm-2.txz

and installed it again, and the outcome is te same.
Obviusly I've done something not wright.

How should I do it to work?


Top
 Profile  
 
PostPosted: Mon Oct 10, 2016 3:40 pm 
Online
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
Hi!

Seems like, I simply forgot to give execute permission to the start script... ASAP, I will change that...

You Can give x permission manually with this command:
Code:
chmod +x /ffp/start/transmission.sh

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Mon Oct 10, 2016 7:54 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2314
MrDini wrote:
Seems like, I simply forgot to give execute permission to the start script... ASAP, I will change that...

Don't do this Mr. Dini. Enable or disable service autostart is and should be user side action. All should be disabled by default except critical ones-sshd for example.
For one time running, run interpreter should be specified, in this case shell for shell scripts:
Code:
sh /ffp/start/transmission.sh start


Top
 Profile  
 
PostPosted: Mon Oct 10, 2016 8:20 pm 
Online
User avatar

Joined: Mon Dec 21, 2015 7:21 pm
Posts: 605
Yes, my packages with start script are disabled by default, except the Transmission packages. Because it requestedby alot of user and I thought, why not? This package Can't cause big problems, like reboots, it just have one error, the dependancie missig error,but it Can be solved by running the script.

But if You say, I won't do it! :)

Quote:
For one time running, run interpreter should be specified, in this case shell for shell scripts:

Code:
sh /ffp/start/transmission.sh start


Yes, I know that. I am not totally noob in linux. :D

BTW: is there a way to execute a shell script, or a binary without root user and with mount option noexec?

_________________
Thanks nas-central the lot of help! :)


Top
 Profile  
 
PostPosted: Mon Oct 10, 2016 8:37 pm 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Thanks, it worked.
Transmission works.


Top
 Profile  
 
PostPosted: Tue Oct 11, 2016 6:58 am 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2314
MrDini wrote:
Yes, my packages with start script are disabled by default, except the Transmission packages. Because it requestedby alot of user and I thought, why not? This package Can't cause big problems, like reboots, it just have one error, the dependancie missig error,but it Can be solved by running the script. But if You say, I won't do it! :)

Mr. Dini, this is not requirement, just a proposal. You have right to do whatever you want. I just suggesting to use the same practice, which is used on standard linux distros.

Code:
sh /ffp/start/transmission.sh start
MrDini wrote:
Yes, I know that. I am not totally noob in linux. :D
This command more likely was addressed to Bohr, illiustrating that even root user needs to know how to run scripts, when executable bit is not set.

MrDini wrote:
BTW: is there a way to execute a shell script, or a binary without root user and with mount option noexec?

Don't know. Never dealed with such situation. Google is your friend.
http://superuser.com/questions/728127/what-does-noexec-flag-mean-when-mounting-directories-on-rhel
Quote:
However, when a script (a text file that begins with she-bang line; i.e., a line that begins with #!) is given to some shells (bash), it will run the executable named on that line (e.g., /usr/bin/perl) and connect the content of the script file to the stdin of that executable, which may not be on that drive.


Top
 Profile  
 
PostPosted: Fri Nov 04, 2016 11:17 am 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Hi guys.

I've a problem with Transmission 2.92:
After installing it worked just fine for some time. Suddenly I can't add any torrent files to downloading.
Restarting Transmission and NSA310 didn't help.
So I uninstalled it and installed it angain and the result is the same.
So I uninstalled it and started version from Zyxel packages: 2.82zypkg002 and this works normaly.

I'd rather use current version than 2.82.
So what should I do to make 2.92 work as it worked before?


Top
 Profile  
 
PostPosted: Fri Nov 04, 2016 6:50 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2314
Bohr wrote:
So what should I do to make 2.92 work as it worked before?

Find that guy, who sabotaged version 2.92 and punish him :lol:
Then force him to enable logging of transmission-daemon and reproduce problematic situation and/or at least paste any error outputs you are getting with 2.92.


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 3:39 pm 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Quote:
Find that guy, who sabotaged version 2.92 and punish him :lol:

Nice. Haven't thhought of it... :o

To get logs I reinstalled 2.92 and... it works, but when adding new torrent it doesn't ask about location of downloadeded content any more.
It's strange, because I've used the same settings.json file.
Is it possible to turn this on?


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 4:21 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2314
How do you add torrents (magnet links?). Via WEB interface or some external client is used?


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 4:32 pm 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Via WEB interface, by clicking "Open Torrent".


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 4:40 pm 
Offline

Joined: Sun Apr 29, 2012 5:24 pm
Posts: 2314
Do you mean this dialog window:
Attachment:
Transmission_add_dialog.png


You do not have the required permissions to view the files attached to this post.


Top
 Profile  
 
PostPosted: Sat Nov 05, 2016 5:20 pm 
Offline

Joined: Sat Jun 25, 2016 1:17 pm
Posts: 19
Yes, exactly.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 213 posts ]  Go to page Previous  1 ... 8, 9, 10, 11, 12, 13, 14, 15  Next

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 93 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group