HOW TO: NZBautomator for Entware-ng

Marvell Kirkwood based
Post Reply
pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Fri Mar 10, 2017 2:04 pm

The easiest way to restart everything is just to re-run the script from the command line.

cd /opt/etc/init.d sh -x S80NZBautomator start

To ensure a restart at boot, follow this step from the beginning of the thread...

Step 4. Place Autonzb.conf into /opt/etc chmod a+x /opt/etc/init.d/S80NZBautomator

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Mon Mar 13, 2017 3:28 pm

OK...time to look for help again...

Everything was running along nicely for months, then I was getting short of disk space and deleted a number of TV series through SickRage.

Ever since, I can't get SickRage to run.

I only use SickRage and NZBGet. NZBGet starts and runs fine.

Here's the output of the script when I run it manually:

-----------------------------------------------------------------------------------------------------------------------------------------------

/ # cd /opt/etc/init.d
/usr/local/zy-pkgs/opt/etc/init.d # sh S80NZBautomator start
S80NZBautomator: line 102: git: not found
S80NZBautomator: line 148: git: not found
SABnzbd not Installed
Checking nzbget... alive.
Shutting down nzbget... done.
Starting nzbget... done.
Couchpotato not Installed
sh: you need to specify whom to kill
Waiting for SickRage to shut down: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, Tired of waiting, killing SickRage now sh: you need to specify whom to kill
46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64, 65, 66, 67, 68, ^C
/usr/local/zy-pkgs/opt/etc/init.d #

-------------------------------------------------------------------------------------------------------------------------------------------------

The first thing I see is that GIT is missing. For the life of me, I can't remember how to re-install it.

Secondly, the script is trying to kill SickRage, but I don't believe it's running.

--------------------------------------------------------------------------------------------

/usr/local/zy-pkgs/opt/etc/init.d # pgrep -f nzb
24084
/usr/local/zy-pkgs/opt/etc/init.d # pgrep -f sick
/usr/local/zy-pkgs/opt/etc/init.d #

----------------------------------------------------------------------------------------------------------------

OK great gurus...where now?

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Wed Mar 22, 2017 9:14 pm

Anybody out there?

I'm getting errors when I try to install git with opkg.

Where now?

kramiz1
Posts: 25
Joined: Sat Sep 24, 2016 2:22 pm

Re: HOW TO: NZBautomator for Entware-ng

Post by kramiz1 » Wed Mar 22, 2017 9:16 pm

pitcritter wrote:Anybody out there?

I'm getting errors when I try to install git with opkg.

Where now?
I'm not guru enough to help you unfortunately. I would just start over if I were you honestly (I did when my install was too messed up to recover).

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Wed Mar 22, 2017 9:20 pm

I'm fine with that but even the hard reset doesn't seem to help me.

I'm pushing the reset on the back of the box for an additional 5 seconds after the second beep then I hear three beeps, but it doesn't give me a full factory reset.

Is there a step I'm missing?

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Wed Mar 22, 2017 10:57 pm

Here's what I'm looking at after a reset...

--------------------------------------------------------------------------------------------------------


NSA325 login: admin
Password:


BusyBox v1.17.2 (2016-05-02 16:34:38 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ $ opkg update
-sh: opkg: not found
~ $

--------------------------------------------------------------------------------------------------------

Any help?

burbulence
Posts: 308
Joined: Sun Feb 17, 2013 10:00 pm

Re: HOW TO: NZBautomator for Entware-ng

Post by burbulence » Sun Mar 26, 2017 8:09 am

pitcritter wrote:Here's what I'm looking at after a reset...

--------------------------------------------------------------------------------------------------------


NSA325 login: admin
Password:


BusyBox v1.17.2 (2016-05-02 16:34:38 CST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

~ $ opkg update
-sh: opkg: not found
~ $

--------------------------------------------------------------------------------------------------------

Any help?
So... firstly not dead... For whatever reason i stopped getting email alerts that posts were being made.

Ok go to firmware/package in the web admin for the NAS and under the package tab ensure Entware-ng is enabled, usually a factory reset of the NAS will disable it., that should sort your opkg error.
Tired of waiting, killing SickRage now sh: you need to specify whom to kill
As you say Sickrage is not running. all i can think of for that is that when you made all the changes to the database it got corrupt. the only thing i am aware of for this is to delete the database and start again. /opt/usr/etc/config/sickbeard/sickbeard.db.

There might be a backup if you are lucky!

Git can be installed using opkg

Code: Select all

opkg install git

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Sun Mar 26, 2017 1:35 pm

Welcome back Burbulence :) we missed you.

Thanks for the reply, but it looks like my problem is a little deeper than I originally suspected.

I'm finding it difficult to re-install Entware after my reset(s).

I've posted for Mitjzelf on the Entware thread. We'll see where that goes.

burbulence
Posts: 308
Joined: Sun Feb 17, 2013 10:00 pm

Re: HOW TO: NZBautomator for Entware-ng

Post by burbulence » Thu Mar 30, 2017 10:50 am

I see you got entware going again, are you back up and running properly now?

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Thu Mar 30, 2017 10:52 am

Limping along for now. Thanks for following up.

It'll be a few days before I get my configuration back where I want it.

I'm still not sure what happened, but the silver lining is that I learned a little more about the system.

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Fri Mar 31, 2017 3:00 pm

Rebooted today and couldn't access SR. Everything had been working fine up til now.

I ran the script in Putty. Here's the output...

/usr/local/zy-pkgs/opt/etc/init.d # sh S80NZBautomator start
From https://github.com/SickRage/SickRage
* branch HEAD -> FETCH_HEAD
Already up-to-date.
From https://github.com/clinton-hall/nzbToMedia
* branch HEAD -> FETCH_HEAD
Already up-to-date.
SABnzbd not Installed
Checking nzbget... alive.
Shutting down nzbget... done.
Starting nzbget... done.
Couchpotato not Installed
Traceback (most recent call last):
File "/opt/share/SickRage/SickBeard.py", line 494, in <module>
SickRage().start()
File "/opt/share/SickRage/SickBeard.py", line 242, in start
sickbeard.initialize(consoleLogging=self.console_logging)
File "/usr/local/zy-pkgs/opt/share/SickRage/sickbeard/__init__.py", line 1100, in initialize
helpers.manage_torrents_url(reset=True)
File "/usr/local/zy-pkgs/opt/share/SickRage/sickbeard/helpers.py", line 1897, in manage_torrents_url
sickbeard.CLIENT_WEB_URLS['torrent'] = ('', torrent_ui_url)[test_exists(torrent_ui_url)]
File "/usr/local/zy-pkgs/opt/share/SickRage/sickbeard/helpers.py", line 1886, in test_exists
h = requests.head(url)
File "/opt/share/SickRage/lib/requests/api.py", line 93, in head
return request('head', url, **kwargs)
File "/opt/share/SickRage/lib/requests/api.py", line 53, in request
return session.request(method=method, url=url, **kwargs)
File "/opt/share/SickRage/lib/requests/sessions.py", line 454, in request
prep = self.prepare_request(req)
File "/opt/share/SickRage/lib/requests/sessions.py", line 388, in prepare_request
hooks=merge_hooks(request.hooks, self.hooks),
File "/opt/share/SickRage/lib/requests/models.py", line 293, in prepare
self.prepare_url(url, params)
File "/opt/share/SickRage/lib/requests/models.py", line 353, in prepare_url
raise MissingSchema(error)
requests.exceptions.MissingSchema: Invalid URL '': No schema supplied. Perhaps you meant http://?
SickRage Started Headphones not Installed
Mylar not Installed
/usr/local/zy-pkgs/opt/etc/init.d #


Looks like something might be off in my SickBeard.py script, although I'm not sure what would have changed.

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Sat Apr 01, 2017 3:43 pm

Disregard...

After another reboot or two everything is back running fine.

Another ghost in the machine...

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Thu Apr 20, 2017 4:48 pm

This may be a little off-topic, but someone here may be able to help.

A few moths ago, my external HDD died. That had been the home for all of my movies. Gone.

Due to a very busy schedule recently, I had never replaced the drive.

Now, I've found some time. I bought a new 5TB external as well as 2X4TB WD Reds for my NSA325.

I backed up all of my TV shows from my old setup (2X2TB in the NSA) onto the new external.

I installed the two new internal drives and got to start everything from scratch. It actually went relatively smoothly.

I moved my TV collection back where it belongs on my NAS.

Now, for the first time in months, I re-installed CouchPotato using Burbulence's script. It too, installed properly.

When I went to configure CP, I found some interesting stuff. First, I needed to look in the config file for the API Key. It's nowhere to be found in the GUI. Second, I can't find any way to set a user name and password. I'd like to allow access to my setup from outside my network (as I do with SB and NZBGet), but without any security, there's no way I'll do that.

Is there something I'm missing here? This is far different from the last version of CP I used.

pitcritter
Posts: 103
Joined: Tue Oct 08, 2013 12:51 am

Re: HOW TO: NZBautomator for Entware-ng

Post by pitcritter » Wed Apr 26, 2017 2:50 pm

In doing some digging around, I wonder if I've come up with something. It may be a red herring, but is this a problem? The script calls:

git pull https://github.com/RuudBurger/CouchPotatoServer
else
git clone https://github.com/RuudBurger/CouchPotatoServer

But when I look on github, it looks like the correct repository is:

git clone https://github.com/CouchPotato/CouchPotatoServer.git

Is this a problem, or is my REAL lack of GIT knowledge showing?

burbulence
Posts: 308
Joined: Sun Feb 17, 2013 10:00 pm

Re: HOW TO: NZBautomator for Entware-ng

Post by burbulence » Sat Jun 03, 2017 10:30 pm

They end up at the same place, /Ruudburger/ is the author, /CouchPotato/ is the directory... both point to the same repo, so either will work

Post Reply