Mounting 1 NetworkSpace in/at/onto another networks space

Post Reply
Posts: 1
Joined: Sun Jan 23, 2011 12:50 pm

Mounting 1 NetworkSpace in/at/onto another networks space

Post by wpnascentral » Tue Jan 25, 2011 9:07 pm

I have 2 Lacie Networks Spaces 1.
One runs 1.1.6 software, the other runs 1.1.8 software
Both have been hacked so on both devices I can run (ssh)/(telnet)

On both devices I can run smbclient and connect to the other device.
mget/mput runs both ways on both devices.

The setup is: 1 device is connected as a local network (server) disk in a (windows) network
The 2nd device is supposed to act as backup for device no 1 - in the same network.
I have connected devices 2 to device 2 with their own switch to take the heat of the central router/switch when the 500GB are copied from
device 1 to device 2 (there is a lan-link from the switch to the router of course)

I use Windows and am not much of an Linux expert. On windows I can run backup programs to copy files from device 1 to
device 2 but I found it more fun to figure out how to let one of the devices take care of back/copy the contents of device 1 to
the other.

Mget/mput is a good start but has a couple of drawbacks. For starters the timestamp of files isn't copied.
And further as handy as using masks can be it fails when you only need to specify the files you DON't want copied.

Anyway - to overcome the timestamp problem I surfed around and think now that the best way to do that is to mount device 1 into/in/on (?) device 2 and use the cp command instead of the mget/mput commands.

So in ssh/telnet on the device I did:
mount -t ntfs //mnt/lace
(and a couple of variations in the slash-settings) but got error:
mount:special device does not exist.

Any ideas on:
1: how to preserve the timestamp when copying files from device to device
2: how to mount device 1 into device 2


Posts: 6251
Joined: Mon Jun 16, 2008 10:45 am

Re: Mounting 1 NetworkSpace in/at/onto another networks spac

Post by Mijzelf » Thu Jan 27, 2011 10:22 pm

wpnascentral wrote:2: how to mount device 1 into device 2
When using samba you'll have to use smbfs or cifs. Not ntfs. For these filesystems to work you need the kernelmodules. I compiled them, and smbfs.ko actually loads. cifs.ko has unresolved dependencies.

Unfortunately you'll also need a mount helper. This could be named mount.smb or smbmount. This evening I tried several binaries from different sources on my box, but noone worked. Maybe you can find a working one. It's called smbfs package, or smbmount. Packages made for Arm NASses could work. The package for Lenny doesn't work. It only wants to mount cifs.

The commands to get it working would be:

Code: Select all

# insmod smbfs.ko
smbmount //server/share mountpoint
Maybe it's easier to try to get rsync server and client running.

Post Reply